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Data Certification issue - Support and Troubleshooting
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KB0695130

Data Certification issue


2508 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Details: We are running a data certification process and we are noticing some behavior in the system that we don't think is normal and would like some assistance with. We do not want to have to add an ITIL role for everyone who needs to perform certification. Additionally, we'd like to know if after we add the certification role to users, if we can still have them go into the CMS portal and not be redirected to the IT version of the portal.

Release


Jakarta ,Kingston

Cause


Platform DESIGN only allows Users with certification role to certify 


Resolution


Add Role "certification" to the users, 
Role certification & certification_admin are the only roles that allow you to do certifications on APPLICATION,

THE SAME RULES WILL APPLY ON THE Service portal. 
Now if you want to redirect these users directly to the portal customization is required to check their login on this role only and redirect to Service Portal 
here is a community based article on role based redirection to the Service Portal 
https://community.servicenow.com/community?id=community_blog&sys_id=cbcda2e9dbd0dbc01dcaf3231f961949 ,

To redirect to CMS site
You may need to add a UI script that checks the role of the user and if the user has only certification role, send them to CMS site
https://community.servicenow.com/community?id=community_question&sys_id=4c8543eddbd8dbc01dcaf3231f9619d7

 


Additional Information


END USERS CANNOT CERTIFY TASK UNLESS THEY HAVE CERTIFICATION ROLE, AND IF THEY ARE ADDED A ROLE THEN THERE NEEDS TO BE CUSTOMIZATION TO REDIRECT END USERS TO THE CMS/PORTAL AS THEY ARE NO LONGER AUTOMATIC REDIRECTION TO CMS/PORTAL.


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