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Symptoms


When using the MID Server Installer for Jakarta Patch 9, the MID will not appear in the instance when completed. The MID Server wrapper log will display the NullPointerException and stack trace below:

2018/06/22 05:19:22 | Exception in thread "StartupSequencer" java.lang.NullPointerException
2018/06/22 05:19:22 | at com.service_now.monitor.AutoUpgrade.getUpgraderServiceToken(AutoUpgrade.java:304)
2018/06/22 05:19:22 | at com.service_now.monitor.AutoUpgrade.uninstallExpectedUpgraderService(AutoUpgrade.java:299)
2018/06/22 05:19:22 | at com.service_now.monitor.AutoUpgrade.cleanup(AutoUpgrade.java:209)
2018/06/22 05:19:22 | at com.service_now.monitor.AutoUpgrade.needsUpgrade(AutoUpgrade.java:115)
2018/06/22 05:19:22 | at com.service_now.mid.services.StartupSequencer.testsSucceeded(StartupSequencer.java:87)
2018/06/22 05:19:22 | at com.service_now.mid.services.StartupSequencer.access$100(StartupSequencer.java:49)
2018/06/22 05:19:22 | at com.service_now.mid.services.StartupSequencer$Starter.run(StartupSequencer.java:279)

 

Environment


Windows OS that supports Jakarta Patch 9.

Cause


The batch file (Installer.bat) for the MID Server Installer causes a null pointer exception that stops the MID server from connecting to the instance. 

Resolution


The following solutions are available.

Upgrade to Kingston as this issue has been fixed in our Kingston release. If upgrading is not possible, you can manually install the MID server per the instructions below: 

Run steps 1-5, then skip to step 16 in the following document: 
 
https://docs.servicenow.com/bundle/jakarta-servicenow-platform/page/product/mid-server/task/t_InstallAMIDServerOnWindows.html 
 
 
This should allow you to be able to properly start up and connect the MID Servers as expected. 

 

Article Information

Last Updated:2018-08-13 16:36:06
Published:2018-08-10