Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Reports on a Homepage are not loading when using Internet Explorer - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Reports on a Homepage are not loading when using Internet Explorer
KB0694680

Reports on a Homepage are not loading when using Internet Explorer


1022 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When using Internet Explorer to access ServiceNow, some reports on a Homepage will not load.

Release


All

Cause


The system property 'glide.ui.escape_text' is most likely set to false. ServiceNow recommends this property be kept to the OOB value of true in order to prevents reflected and stored cross-site scripting attacks.

This issue stems from the query being used by the reports, which likely contain special characters such as <>!= that are not being escaped properly. The reason why this issue only occurs in IE is due to a difference in behavior between browsers. While Chrome and Firefox have built-in preventative measures which will handle the issue more elegantly, IE will throw an error when it encounters un-escaped characters which in turn breaks the report functionality. Note that this only affects graphical reports (line, pie, etc.). List reports should still work regardless of the property value.

Resolution


Set the system property 'glide.ui.escape_text' to true.

Additional Information


Documentation:

- High Security Settings | https://docs.servicenow.com/csh?topicname=c_HighSecuritySettings.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.