Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Reference variables on a Catalog Item do not show the 'Open Record' link in the popup - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Reference variables on a Catalog Item do not show the 'Open Record' link in the popup
KB0694672

Reference variables on a Catalog Item do not show the 'Open Record' link in the popup


3627 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Reference variables on Catalog Items, as opposed to Reference fields on a form, do not show the 'Open Record' link in the corner when the reference popup is displayed.

Reference variable:

 

Reference field:

Release

All

Cause

This is not a bug. It is a design choice made by development to leave off the 'Open Record' link in the popup for a reference variable.

Resolution

There is the option of setting the system property "glide.sc.variable.reference.clickthrough" to true which will alter the behavior for the reference icon.

If you click on the icon, you will be redirected to the reference record instead of being presented with the popup. However, this a system wide change.

Related Links

Additional Documentation link:

https://docs.servicenow.com/csh?topicname=r_ServiceCatalogProperties.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.