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Symptoms


When creating a notification trigger for RITMs, a customer option was not available in the filter condition for the stage field; however, the option was visible on the RITM form.

Release


Jakarta Patch 8

Cause


The custom stage was generated and hard coded to the stage field dynamically from an execution plan through the Start Peer Task business rule. The stage values are determined by the tasks' short description from the related execution plan. As these stages are not configured on the sys_choice table, it cannot be selected from a filter condition.

Resolution


In the notification trigger, use an advanced script to return true when the field changes to the desired value. For example:

 

if (current.stage.changesTo('Custom_Stage')) {

   return true;

}

 

Article Information

Last Updated:2018-08-11 09:18:08
Published:2018-08-11