Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Users not able to change the language in the login page. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Users not able to change the language in the login page.
KB0694063

Users not able to change the language in the login page.


3882 Views Last updated : Nov 22, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Users are not able to change the language on the login page. When users try to select a language, the page refreshes and a default language is selected.

Cause

There is a user preference named user.language. If the value in the value field of this user preference has some language code for the guest users, then the users won't be able to change the language on login page as they are guest users before logging in. 

Resolution

1) Navigate to User Preferences (sys_user_preference table) from the Filter Navigator.

2) Find user.language with user field empty and open it.

3) See the XML of the user preference. If the user value is "guest" then you have selected the correct one. If not find the user preference with the user as "guest"(Note: Users cannot see the value in the user field for "guest" users as well as "snc" users in both list and form view of the user preference. So we have to see the XML of the record to find if it is for guest)

4) After finding the correct user preference, remove the value in the value field and update it

5) If using "guest", run the following script in Scripts - Background to flush the cache to complete this fix:

GlideCacheManager.flush('frequest_use_cache');

 

Additional Note:

Please make sure that the languages you want to select are marked as active in the sys_language table.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.