Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Security constraint on embedded list add new row showing "Security Prevents Writing to this Field" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Security constraint on embedded list add new row showing "Security Prevents Writing to this Field"
KB0693914

Security constraint on embedded list add new row showing "Security Prevents Writing to this Field"


1660 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When attempting to insert a row on a m2m list inside of an embedded list as a non admin, there is a good chance, you will receive a security constrain error.

The error will say, "Security Prevents Writing to this Field" below the search field.

 

 

Cause


The reason this is happening is that there is a global (*.none) ACL for list edit which has a role of Admin.

This will restrict the use from editing the list is they are not an admin which is what they are doing in an embedded list adding a row.

 

Resolution


Create a new list edit ACL which is for the table that is in question that follows the best practices of your business requirement.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.