Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
I run a Discovery scan on a computer with the MAC OS and got an "TCP connection dropped" error in the Discovery log - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • I run a Discovery scan on a computer with the MAC OS and got an "TCP connection dropped" error in the Discovery log
KB0693876

I run a Discovery scan on a computer with the MAC OS and got an "TCP connection dropped" error in the Discovery log


1246 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


I run a Discovery scan  on a computer with the MAC OS and got an "TCP connection dropped" error in the Discovery log.

Release


Any

Environment


Discovering a MAC OS computer.

Cause


Apple changed how SSH login responds back to bad credential requests. Bad credential requests occur in normal operation when Discovery tries different SSH credentials to determine the correct credential to use in the future for that target device. 

Also, you must be using sncssh library, not j2ssh library to discover Mac Sierra.

Resolution


To enable sncssh for all MID servers, set mid.property.ssh.use_snc = true in MID Server -> Properties. 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.