Issue
When a field changes on a form it's not showing in the activity stream for some users.
Here is an example:
Updating assignment group on the incident form is showing in the activity stream for admin:
But not for the user in the group CAB Approval, the incident is assigned to even though it shows checked in configure available fields.
Release
All
Cause
User preference <tablename>.activity.filter for user doesn't have value for '<field not showing>,true'
In above: User preference 'incident.activity.filter' for user doesn't have value for 'assignment_group,true'
Resolution
Related Links
If you want to read more about Configure the activity filter, here is the doc:
NOTE:
If you want to not show updates of a particular field on the Activity Stream, but allow users to add it if they wish, then set the preference value with the following pattern:
<field_name>,<display_value>; so for example like "assignment_group,false;"
This will result in the field listed in the Activity Stream filter, but the check box will not be checked.