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Symptoms


When field changes on a form its not showing in activity stream for some users.

Here is an example:

Updating assignment group on the incident form is showing in activity stream for admin:

But not for the user in the group CAB Approval, the incident is assigned to even though its shows checked in configure available fields.

Release


ALL

Cause


User preference <tablename>.activity.filter for user doesn't have value for '<field not showing>,true' 

In above: User preference 'incident.activity.filter' for user doesn't have value for 'assignment_group,true'

Resolution


1. Ask the user to uncheck and check (assignment group) field from filter icon on the incident form that is not appearing, this will update the user preference <tablename>.activity.filter and will add <missing field>,true 
 
Admin can do that too for the user by impersonating the user. 
 
2. If you want all users to see specific fields in activity stream create user preference with these details: 
 
Name: <table_name>.activity.filter 
 
Value: All the fields you want users to see
Here is an example:
assigned_to,true;cmdb_ci,true;incident_state,true;impact,true;priority,true;opened_by,true;work_notes,true;comments,true;*Email*,true;*Relations*,true;*Attachments*,true;assignment_group,true 
 
System: Check this box 
 
User: leave it blank
 
Save and flush the cache. 

Additional Information


If you want to read more about Configure the activity filter, here is the doc:

https://docs.servicenow.com/bundle/london-platform-user-interface/page/administer/form-administration/task/configure-activity-filters.html

Article Information

Last Updated:2018-08-03 00:22:39
Published:2018-07-30