Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Number of records returned upon a query is different depending on the user - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Number of records returned upon a query is different depending on the user
KB0693827

Number of records returned upon a query is different depending on the user


422 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When a user submit a query to get records from a table based on dates, the result differ depending on whom submitted the query

Release


Jakarta, Kingston

Cause


Users are in different timezone

Resolution


This is occurring when users are part of a different timezone set in the sys_user record. This is expected as different timezones might include different records when accounting for the very start or very end of the month depending on the number of hours from other user in a different timezone. You can test it by changing the user's timezone to match whatever the other affected user is. 

For example, if you are looking at a report that is the whole month of June it means the differences will either be on the first of the month (June 1st or the last of the month (June 30). 

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.