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Symptoms


Client Scripts are not running on Service Portal. They run perfectly on the Standard UI. 

Release


All Releases

Cause


The cause of client scripts not running on Service Portal is if the "UI Type" is set to "Desktop".

For Catalog Client scripts to run on Service Portal, the UI Type needs to be set to "Mobile/Service Portal" or "All".

Resolution


To fix this issue, change the UI Type of the client script to "Mobile/Service Portal" or "All". 

Additional Information


Make sure that the scripts are using Mobile compatible API since the UI type is set to Mobile / Service Portal. If the API is not compatible to Mobile platform, the scripts will throw errors and not run as expected. 

Below links have more information on what functions are supported and/or not supported on Service Portal.

https://docs.servicenow.com/bundle/jakarta-servicenow-platform/page/build/service-portal/concept/unsupported_client_scripts.html 

https://docs.servicenow.com/bundle/kingston-application-development/page/script/client-scripts/reference/r_MobilePlatformMigrationImpacts.html 

Article Information

Last Updated:2018-11-16 12:56:51
Published:2018-07-26