Notifications

183 views

Description

Order Guides show HTML tags in variables within Service Portal if a Checkbox variable is present

Steps to Reproduce

1. Log into an instance
2. Create an Order guide
3. Add a couple of label variables and include HTML in the question fields
sample 1- <p></p> <table style="width: 100%; border-bottom: 1px solid #FF0000;"> <tbody> <tr> <td><b><font color="#FF0000">HTML</font></b></td> </tr> </tbody> </table>
sample 2- <b>testing second label</b>
4. Create a check box variable as well
5. Navigate to Service Portal and search for your Order Guide. Open it.

Expected Behavior: Order guide renders the HTML properly and does not show tags.
Actual Behavior: Order guide shows HTML Tags

6. Remove the Check box variable and notice that the Order Guide Renders the HTML as expected in Service Portal

Through the normal UI, you can see the HTML tags (this is not a problem), the issue is that in the Service Portal the HTML is not rendering properly.

This used to work in Helsinki but no longer works in Jakarta.

Workaround

This issue is under review. To receive notifications when more information is available, subscribe to this Known Error article by clicking the Subscribe button at the top right of the article. If you are able to upgrade, review the Fixed In or Intended Fix Version fields to determine whether any versions have a planned or permanent fix.

 


Related Problem: PRB1182292

Seen In

There is no data to report.

Fixed In

Kingston Patch 9
London

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2018-11-08 10:34:17
Published:2018-07-27