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  • User in the same domain as knowlege base cannot see expected knowledge article in KB search
KB0692738

User in the same domain as knowlege base cannot see expected knowledge article in KB search


412 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


User is trying to search for knowledge article in the knowledge base in the same domain user is in and article is not found.

Here is one example: Knowledge Base is in Domain ACME and User is also in Domain ACME and hence user should have visibility on all the knowledge articles in domain ACME but the user is unable to find expected article in Domain ACME.

ACME ITIL user in ACME domain is expecting to see this knowledge article:

But when user search from knowledge homepage or incident knowledge searches unable to search for the article.

Release


ALL

 

Cause


User doesn't have roles mentioned in Can Read User Criteria for Knowledge Base. Even though the user is able to see the article in kb_knowledge list view since the user has access in that domain but due to user criteria conditions, the user will not be able to search for the articles in knowledge homepage or from the incident form knowledge search. 

Resolution


Adjust the user criteria roles and make sure user has the roles mentioned in Can Read User Criteria: 

Additional Information


Here is the doc where you can read more about User Criteria for knowledge base:

https://docs.servicenow.com/csh?topicname=t_SelectUserCriteria.html&version=latest


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