Issue
Symptoms
There are open alerts for a Business Service but they're not loaded on the Event Management Dashboard when drilling into the Business Service. The alert list is loaded if user stays on the Dashboard and selects the Business service. This affects users without 'evt_mgmt_admin' role.
Release
Jakarta and newer releases.
Cause
- Loading of the alerts should be sufficient for users with 'evt_mgmt_operator' role.
- The Business Service Map when drilled down from Event Management Dashboard, is making calls 'ImpactAdminActionsProcessor' processor. This processor is limited to users with 'evt_mgmt_admin' role by 'ImpactAdminActionsProcessor' ACL.
Resolution
This is fixed in PRB1253418, which is targeted for London release.
Additional Information
For older releases (Jakarta and Kingston), the use the following workaround:
- Navigate to System Security > Access Control (ACL)
2. Search for Name = ImpactAdminActionsProcessor
3. Open the ACL and add "evt_mgmt_operator" and/or "evt_mgmt_user" role