Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Creating an incident on Service Portal does not hide variables on the incident record despite Catalog UI Policies - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Creating an incident on Service Portal does not hide variables on the incident record despite Catalog UI Policies
KB0692648

Creating an incident on Service Portal does not hide variables on the incident record despite Catalog UI Policies


863 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Creating an incident through a record producer item on Service Portal doesn't hide variables in the Incident Variable Editor on the incident record even though these variables should be hidden based on catalog UI policies and not seeing the same behavior on the same release/patch level out of box.

Release


All releases.

Cause


Check if the widget in use on the portal is customized because this could be the underlying cause.

Resolution


If there is a customized widget in use, try the corresponding out-of-box widget instead. If using the out-of-box widget allows the catalog UI policies to hide the variables as expected in the Incident Variable Editor on the incident record, then it's an issue with the custom widget and not with the catalog UI policies.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.