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Availability calculation not honoring the amount of hours made available - Support and Troubleshooting
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  • Availability calculation not honoring the amount of hours made available
KB0692572

Availability calculation not honoring the amount of hours made available


538 Views Last updated : Jul 20, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

On the resource_aggregate_monthly table, the availability for some users/months is not being affected by the expected value when changing the number of hours allocated for that user.

Cause

If a user is over-allocated for a specific day in the analyzed period, removing the allocated hours above the average FTE settings will have no impact on the user's availability.

As an example, for the following scenario, when average FTE is set to 8 hours per day: 

  • User: scrum_user_1; 
  • Date: 01-01-2018;
  • Currently allocated hours: 10; 

The user's current availability for 01-01-2018 is 0 hours. By removing 2 hours from any allocation on this user/date, his allocation will become 8 hours, but his availability will not change as the currently allocated hours are still greater than or equal to the average FTE. 
If you remove 3 hours, the allocation will be reduced by 3, becoming 7, but the availability will only change by 1, becoming 1 hour. 


Resolution

This is the OOB expected behavior.


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