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Symptoms


  • MID Server agent log will show "SEVERE *** ERROR *** Failed to rename ECC enqueued item from ecc_queue.<number>.tmp to ecc_queue.<number>.xml"
  • Delay in processing ecc queue records
  • Finding multiple ecc queue input records for one output record
  • MID Server Issues records created for:
    • A MID Server with a duplicate name or sys_id was prevented from connecting. Install path: C:\....\agent. This issue must be manually resolved.
    • The home directory changed from C:\....\agent to C:\....\agent. This issue must be manually resolved.

Release


All

Cause


This issue occurs in 3 known situations:

  1. When multiple MID Server services point to same mid server directory.   More details on resolving this can be found in:
          KB0743043 How to debug and resolve the "A MID Server with a duplicate name or sys_id was prevented from connecting." Issue
  2. When a MID Server is restarted while there are still xml input records left unsent in the ECCSender folder.  This is due to:
          KB0743121/PRB1330405 MID Server will re-run completed jobs after a restart, if the job results are still queued in the ECCSender folder
  3. The agent log will show this error is from a thread that is "Running system command: restartService" or also logs "Ignoring outdated restart request as MID Server was recently restarted.". These can be ignored.

Article Information

Last Updated:2019-03-08 06:16:02
Published:2019-03-08