Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Comments and/or Worknotes do not show on the activity stream - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Comments and/or Worknotes do not show on the activity stream
KB0692478

Comments and/or Worknotes do not show on the activity stream


9027 Views Last updated : Jul 22, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

Comments and/or Worknotes do not show on the activity stream even after doing the following:

- Saving the record

- Using the 'Post' button

Release

All versions

Cause

If you have verified there are no ACL restrictions or custom scripting processes interfering, it is likely then that Auditing is not enabled for the table. Auditing is required as the comments and work_notes fields do not work on non-audited tables. The data entered is stored in the audit history for the record. This issue is normally seen in custom tables since Auditing is enabled by default on OOB tables.

Resolution

1. Go to sys_dictionary and find the 'Collection' type record for the table with the issue:

 

2. Open it and mark the 'Audit' checkbox. Save.

Related Links

- Auditing: https://docs.servicenow.com/csh?topicname=audited-tables-2.html&version=latest

- Enable Auditing for a Table: https://docs.servicenow.com/csh?topicname=t_EnableAuditingForATable.html&version=latest

- Journal Fields: https://docs.servicenow.com/csh?topicname=r_JournalFields.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.