Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Approval - User Activity is not waiting for all the users to approve the approval records - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Approval - User Activity is not waiting for all the users to approve the approval records
KB0692045

Approval - User Activity is not waiting for all the users to approve the approval records


587 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Problem with Manual Approvals in Workflow

Release

KP5

Cause

The out of the box "Before Query" business rule named "Approval Query" has skipped during the upgrade 

Resolution

There is a "Before Query" business rule named "Approval Query" that has the skipped the upgrade. This business rule has been turned to Active "false" in Kingston version. Since it has skipped the upgrade, the business rule was still "active" in the prod instance and it altered some of the queries to the "Approval" table and therefore the issue occurred.

Revert the business rule to the OOB version resolved the issue.



The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • Cookie Preferences
  • © 2025 ServiceNow. All rights reserved.
We use cookies on this site to improve your browsing experience, analyze individualized usage and website traffic, tailor content to your preferences, and make your interactions with our website more meaningful. To learn more about the cookies we use and how you can change your preferences, please read our Cookie Policy and visit our Cookie Preference Manager. By clicking “Accept and Proceed,” closing this banner or continuing to browse this site, you consent to the use of cookies.