Issue
Attempting to impersonate a user results in the error message: "The user you selected could not be impersonated".
Cause
The user account that is being selected is missing a User ID.
Resolution
Administrators can associate a user ID value to the user's account so their name can be selected from the Impersonate User pop up menu.
Related Links
The scenarios mentioned below pertain to the user that is being selected from the Impersonate User search bar-
- User has an inactive account or is locked out
- User is an admin (non-admin users cannot impersonate an admin user, even if they have the impersonator role.
- User has the "Web service access only" checkbox selected
For each of these search attempts, impersonators will not see the user name, instead they will see "No matches found" returned.
If none of the above resolve the issue, you may check the ImpersonateEvaluator script include to see if it has been modified. Modifying this script include is also known to have caused this issue.