Issue
Symptoms
When tapping the Magnifying Glass icon on a reference field in the Mobile UI, the resulting list is not sortable or sorted as desired.
Environment
ServiceNow Mobile Browser UI, ServiceNow Mobile App
Cause
The Mobile UI does not support end user sorting options for Reference lookup lists, and the User Preferences that dictate the sort method may not exist or be configured incorrectly.
Resolution
Although adding Sort options from this list is not possible, it is possible for administrators to setup a default Sort for all users by creating 2 User Preference records. For example, if the admin would like the default sort for the Business Services[cmdb_ci_service] field to sort alphabetically ascending on the 'name' field, the following 2 User Preferences would need to be created:
User Preferences -> New
Name: m.cmdb_ci_service.db.order.direction
Type: string
Value: ASC
System: true
Name: m.cmdb_ci_service.db.order
Type: string
Value: name
System: true
It is important to keep in mind that User Preferences linked to a specific User will override the default User Preference files.