Issue
Symptoms
Duplication entries created in 'sys_history_line' table for same audited (for example incident) record with same user.
Release
Any supported release.
Cause
Duplicate entries created in 'sys_history_line' table, when the users are viewing the audited (for example incident) record, but having different domain / Date format / Language / Time Zone.
This is expected design behavior, because new sys_history_set would be built based on the domain / Date format / Language / Time Zone of the user.
Resolution
Though the sys_history_line record appears as duplicate, actually they are not, as they will have different set field ('sys_history_set'), this is an expected design behavior.