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Why are duplicate entries created in the 'sys_history_line' table? - Support and Troubleshooting
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KB0691454

Why are duplicate entries created in the 'sys_history_line' table?


3534 Views Last updated : Apr 19, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Duplication entries created in 'sys_history_line' table for same audited (for example incident) record with same user.

Release


Any supported release.

Cause


Duplicate entries created in 'sys_history_line' table, when the users are viewing the audited (for example incident) record, but having different domain / Date format / Language / Time Zone.

This is expected design behavior, because new sys_history_set would be built based on the domain / Date format / Language / Time Zone of the user.

Resolution


Though the sys_history_line record appears as duplicate, actually they are not, as they will have different set field ('sys_history_set'), this is an expected design behavior.

Additional Information


Audit history and History set

History List


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