Notifications

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Symptoms


When we are using Password Reset Process, we have an option to enroll devices for Two Factor authentication.

During this process, we are seeing that "NEWLINE" in the message body is interpreting as "?" in the SMS in iPhones

https://docs.servicenow.com/bundle/london-servicenow-platform/page/administer/login/task/t_EnrollUsingSMS.html

Release


When working Password Reser Plugin

Cause


In the email body we are seeing a NEW LINE and it's causing the issue for us here.

 

Resolution


Goto the email Notification.

/nav_to.do?uri=sysevent_email_action.do?sys_id=7cd0c421bf200100710071a7bf0739bd%26sysparm_view=advanced

Please remove the space between 


Use this verification code to verify your identity: 
<<SPACE>>
${event.parm2} 

and set it as "Use this verification code to verify your identity: ${event.parm2}" in Message and SMS. 

 

Article Information

Last Updated:2018-12-28 13:06:25
Published:2018-12-28