Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Password Reset SMS verification code sent with a [question mark]"?" when you are using iPhones - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Password Reset SMS verification code sent with a [question mark]"?" when you are using iPhones
KB0691022

Password Reset SMS verification code sent with a [question mark]"?" when you are using iPhones


1505 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When we are using Password Reset Process, we have an option to enroll devices for Two Factor authentication.

During this process, we are seeing that "NEWLINE" in the message body is interpreting as "?" in the SMS in iPhones

https://docs.servicenow.com/csh?topicname=t_EnrollUsingSMS.html&version=latest

Release


When working Password Reser Plugin

Cause


In the email body we are seeing a NEW LINE and it's causing the issue for us here.

 

Resolution


Goto the email Notification.

/nav_to.do?uri=sysevent_email_action.do?sys_id=7cd0c421bf200100710071a7bf0739bd%26sysparm_view=advanced

Please remove the space between 


Use this verification code to verify your identity: 
<<SPACE>>
${event.parm2} 

and set it as "Use this verification code to verify your identity: ${event.parm2}" in Message and SMS. 

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.