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A user is restricted catalog Item acess even if the ACLs grants the read access to that user role - Support and Troubleshooting
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  • A user is restricted catalog Item acess even if the ACLs grants the read access to that user role
KB0690987

A user is restricted catalog Item acess even if the ACLs grants the read access to that user role


3384 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


 A user does not have access to the sc_cat_item table even when the ACL grants the read access to that user role

Release


All

Cause


Navigate to service catalog > properties > under "Security", check if the User Criteria is enabled 

Property name : glide.sc.use_user_criteria

When this property is enabled, any user criteria defined for the service catalog will be taken into consideration over the defined ACLs.

Service catalog has a related list for user criteria "Available for" and "Not Available for": If there is defined user criteria and the user criteria for the service catalog is enabled, it overlooks all the ACLs and follows the defined user Criteria.

Resolution


  • Navigate to sc_cat_item.LIST
  • Open the service catalog item that has the issue, that is the catalog item which the user is unable to view
  • Scroll to the bottom of the record, and notice that there is "Available for" and "not available for" related list
  • Adjust the defined user criteria to result in the expected access grant 

Additional Information


-- Learn more about user criteria using the below document:

https://docs.servicenow.com/csh?topicname=t_AppUserCritItemsCat.html&version=latest

-- To understand the work flow of the User criteria for service portal:

https://docs.servicenow.com/csh?topicname=user-criteria.html&version=latest


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