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F5 Load Balancers' Install Status Set to Inactive State After Discovery - Support and Troubleshooting
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  • F5 Load Balancers' Install Status Set to Inactive State After Discovery
KB0690801

F5 Load Balancers' Install Status Set to Inactive State After Discovery


2096 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

There are cases where F5 load balancers' install status will get set to an inactive state after discovery, even though they are not actually inactive. If used in Service Mapping, you may see errors like "host [IP_ADDRESS_OF_LOAD_BALANCER] ignored since its install status is inactive"

Release

Potentially any version can be impacted.

Cause

This can be due to F5s being in a cluster and being in a standby state. During horizontal discovery, the 'SNMP - F5 BIG-IP - System' sensor will set the install status of the load balancer based on the value returned from its corresponding probe. The value it is looking for in the payload is "sysCmFailoverStatusId". In cases where load balancers are in a standby state, that value can be something that can get translated to an inactive state in ServiceNow.

Resolution

  • Find you 'SNMP - F5 BIG-IP - System' Sensor (Sensors > SNMP - F5 BIG-IP - System)
  • Look for the following function in the script:

_convertOperStatus : function(deviceOperStatus) { 
     if (deviceOperStatus == '1') 
          return 2; 
     else if (deviceOperStatus == '2') 
          return 2; 
     else if (deviceOperStatus == '3') 
          return 2; 
     else if (deviceOperStatus == '4') 
          return 1; 
     else 
          return -1; 
}

  • In order to resolve this issue you will have to modify that function in the sensor to set the operational status to 1 when we retrieve a standby value from the F5 discovery. 

Related Links

  • See the following documentation from F5: https://support.f5.com/csp/article/K14399
  • In case the link goes down, the table from that document is below:

Example:

  • Check the payload from the "SNMP - F5 BIG-IP - System" probe after discovery
  • Look for the following result in the payload:
    • ""sysCmFailoverStatusId":"[SOME_NUMBER_WILL_BE_HERE]""
  • If the value is "3", you can see from the table above that it is a "standby" state
  • According to the function above, it will return a value of "2" which is one of the install status inactive state choices. 
  • If you modify that script to return "1" instead of "2," upon next discovery of the load balancer it should accurately set the install status to active. 

 


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