Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to receive inbound attachments on 'table_name' via static WSDL when using AttachmentCreator SOAP web service - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to receive inbound attachments on 'table_name' via static WSDL when using AttachmentCreator SOAP web service
KB0690210

Unable to receive inbound attachments on 'table_name' via static WSDL when using AttachmentCreator SOAP web service


805 Views Last updated : Jan 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


In the response body we can see that the attachment is not created in ServiceNow and in payload we see the message:
"Could not find a record in table <table_name> with sys_id <sysID>". 
 
The sys_id is the one of the record to be updated.
 

Release


Jakarta, Kingston.

 

Cause


The issue is due to the system property glide.soapprocessor.large_field_patch_max having a default value of 512 KByte. This is an expected fixed value rather than a cut-off limit, therefore any attachment file with smaller size than this will not be created.

 

Resolution


If you are using SOAP to perform the insert, the payload file size limitation is overridden by the value set in the system property glide.soapprocessor.large_field_patch_max. 
When sending a file with a smaller size via the AttachmentCreator, the value should be set accordingly in the system property.
However, the AttachmentCreator SOAP web service is not recommended. Instead, use the REST Attachment API to manage attachments with web services.
 

Additional Information


Related documentation page: AttachmentCreator SOAP web service

Limitations of the SOAP Attachment Creator webservice with Domain MSP

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.