Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Admins getting security constraints even though ACL has Admin override checked - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Admins getting security constraints even though ACL has Admin override checked
KB0690072

Admins getting security constraints even though ACL has Admin override checked


6155 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Admins are unable to see the records in a table:

  • They are getting "Number of rows removed from this list by Security constraints: 20" Error when trying to access table or a record
  • After debugging ACL you noticed Admin Override is checked, which means admin should pass that ACL

Cause

  • System Property 'glide.security.admin.override.accessterm' is false. 
  • This property when set to false means that, if there are a number of ACLs on the same table/field and admin override is false on one of them, then admin override for all ACLs are considered as false. 

Resolution

  1. Search for the system property 'glide.security.admin.override.accessterm' in sys_properties table:
    • https://<instance-name>.service-now.com/sys_properties_list.do?sysparm_query=name%3Dglide.security.admin.override.accessterm
  2. Change the value from 'false' to 'true'
  3. If the property is not available on the instance you can add it with the following details:
    • Name: glide.security.admin.override.accessterm
    • Type: true/false
    • Value: true
    • Description: When it is set to true, it evaluates the admin overridable condition at the access term level.

Related Links

Here you can read more about this system property: Admin Override Property


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.