Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
End-of-central-directory signature not found when unzipping a MID Server installer to Linux - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • End-of-central-directory signature not found when unzipping a MID Server installer to Linux
KB0689682

End-of-central-directory signature not found when unzipping a MID Server installer to Linux


11765 Views Last updated : Aug 24, 2022 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

End-of-central-directory signature not found. Either this file is not a zip file, or it constitutes one disk of a multi-part archive.
In the latter case, the central directory and zip file comment will be found on the last disk(s) of this archive.

After downloading the MID Server into a Linux server, and when attempting to unzip the package file, this message is shown:

$ unzip mid.<version>-mm-dd-yyyy__patchx-xxxx.linux.x86-64.zip
Archive: mid.<version>-mm-dd-yyyy__patchx-xxxx.linux.x86-64.zip

Cause

Unzip cannot find the line of code that signals the end of the archive. Given the usually large size of the MID Server package, the file was probably corrupted during download.

Resolution

  1. Use the command unzip -t to check if the zip file is damaged.
  2. If it's damaged, download the MID Server file again.
  3. Unzip the file in a Windows environment.
  4. Transfer (FTP) the file to your Linux server in binary mode.
  5. Unzip the file in the Linux environment.

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.