Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Project End Date does not take user value causing Planned Duration to be set to zero - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Project End Date does not take user value causing Planned Duration to be set to zero
KB0689039

Project End Date does not take user value causing Planned Duration to be set to zero


423 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

After upgrading to Kingston, an issue was found with the 'Planned duration' field on Project and Project Task forms, where it is calculating duration as Zero value.

On the Project Task Form, an issue is also observed with the Project End Date field, which is not taking the user input value. Hitting the Save button will revert back the End Date to either the start date or the current date value.

Release

First observed in Kingston Patch 4.

Cause

Customized Script Includes 'AjaxProjectTaskUtil' and 'ProjectTaskManagerUtil'.

Resolution

Revert the Script Include 'ProjectTaskMangerUtil' to OOB.

If that does not fix the issue, check and revert if necessary the Script Include 'AjaxProjectTaskUtil'.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.