Description
Symptoms
Duplicate workflows attached to the same parent workflow.
Release
Kingston Patch 5
Cause
Custom business rule which had a current.update
Resolution
The customer had a custom business rule that had a current.update within it and also the parent workflow which contained the two parallel workflow activities had the same count.
All of the three workflows had the same order of 100. Changed this to be different for all of the three workflows to avoid conflict.
Also commented out the current.update and also changed the count of the parallel flow activities to 0 and 1.