Issue
Popup window when hovering over a reference icon shows a different form section than the top form section.
Cause
The cause of the unexpected behavior of the popup is the lack of sys_popup views set up for the specified table. If the system attempts to access a non-existent view, it can result in unpredictable outcomes, such as showing an arbitrary section of a form instead of the expected popup.
For example:
when you are on the Incident form and move the cursor over the reference icon close to the pre-filled Assigned To field, if there is no defined sys_popup view for the sys_user table, it could result in the display of an unforeseen section of the form.
Resolution
The following steps can be taken to resolve this issue in any instance:
- Navigate to- https://<your-instance>.service-now.com/<table_name>.do?sysparm_view=sys_popup
This will show a form even if one does not yet exist, it will pull fields from the default view. - Right Click the header and choose Configure → Form Layout
- Users can click save to create the view as it looks now, or they can modify the fields/form sections displayed by customizing it to their needs and clicking save.
- There should now be a sys_popup view for this table which will be visible upon hover of the reference icon.