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Caller (caller_id) field does not return all user records on mobile as compared to desktop where it does - Support and Troubleshooting
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  • Caller (caller_id) field does not return all user records on mobile as compared to desktop where it does
KB0688919

Caller (caller_id) field does not return all user records on mobile as compared to desktop where it does


1327 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


On mobile, when the Caller (caller_id) field lookup button is used it does not return all user records on sys_user as compared to desktop version where it does return all sys_user records.

Release


All releases

Environment


This issue is application only for mobile web and mobile app

Cause


Working as designed due to the caller_id field being dependent upon the company field.

For example, if the company of an incident record is "XYZ" and there are 20 users whose company is set to it then caller_id would only return 20 records (instead of all records in sys_user) because of the dependency.

Resolution


If the expected behavior is not desirable the dependency to the company field on caller_id can be removed so that caller_id would return all records from sys_user instead.

Additional Information


The reason why on desktop version it returns all user records for caller_id even if the company dependency is in place is due to company field not being added to the form. When this is the case it ignores the dependency and thus all user records are returned.

PRB601488 is currently opened to address this behavior.


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