Issue
Symptoms
vCenter automatically creates an default Service Account with just the vCenter UUID even though there is already a Service Account created for the vCenter.
Release
Jakarta and newer
Cause
- There are two options to discover vCenter
- Through Cloud Service Account
- Through vCenter host discovery
- Both options create default service accounts.
- Option 1 was a bug that was fixed
- Option 2 was due to incorrect Account ID configured for vCenter Service Account. The way vCenter Host discovery identify existing Service Accounts are through their Account ID which has to be the vCenter UUID.
Resolution
Deleting the default account that was created:
- Go to relationship table: cmdb_rel_ci_list.do
- Find the relationship record(s) with the following conditions:
- Parent is the Datacenter(s) hosted on the vCenter
- Child is the service account that was automatically created
- Export for backup then delete the relationship records found.
- Go to Cloud Management > Service Account
- Locate the default Service Account that was created and delete
Correcting existing Service Account
- Go to Cloud Management > Service Account
- Identify the configured Service Account that was duplicated
- Obtain the vCenter UUID for the Service Account
- Under the Service Account's Account Id field, enter the correct vCenter UUID found in step 3 and save.