Issue
On Service Portal, when a user switches the language from English to a different language, the name of a catalog item does not translate while everything else on the page does.
Release
All releases
Cause
The reason the translation was not displaying is because the Name field at the dictionary level was set to a type Translated Field. The correct type should be Translated Text.
Resolution
1. On the sc_cat_item table, go to the Dictionary record of the Name field.
2. Change the Type field from Translated Field to Translated Text.
https://instance-name.service-now.com/nav_to.do?uri=sys_dictionary.do?sys_id=9707fa996f412100b23960444b3ee4c6
3. Make sure that the translation for the name of that particular item is added to the Translated Text table: sys_translated_text
Related Links
For more information, check out the following product documentation: