5 views

Symptoms


When trying to add comments to a a cusotm table (extending case) using the HRI Case Tab Menu widget the comment is not saved. 

There is an error either in the Dev tools console or the UI. "Write operation against 'sn_hr_core_case_<cusotm name>' from scope 'rhino.global' has been refused due to the table's cross-scope access policy"

Release


Istanbul and above

Cause 


The custom table does not allow updates from other scopes.

Resolution


Edit the table definition for that custom table to allow update access from other scopes. You may need to elevate roles to do so.

  1. Navigate to System Definition > Tables.
  2. Search for and open the record for the custom table.
  3. In the Application Access section, check the box for 'Can Update'.

Additional Information 


Docs which explain how to enable scope access. 
https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/table-administration/task/t_CreateATable.html 

Article Information

Last Updated:2018-06-13 09:11:52
Published:2018-06-06