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Troubleshooting an Incident form showing the State being set to 'In Progress' twice - Support and Troubleshooting
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  • Troubleshooting an Incident form showing the State being set to 'In Progress' twice
KB0688332

Troubleshooting an Incident form showing the State being set to 'In Progress' twice


574 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


 The activity in the incident form shows state is updated twice

Release


Kingston Patch 3

Cause


The Business rule 'Trigger RAVE Alert (new to in progress)' is the cause of this issue. 

Resolution


The Business rule "Trigger RAVE Alert (new to in progress)" is active on prod instance and it is making a "current.update()" action in its script.
 
It is recommended that we should never use "current.update()" in a business rule, as it will cause recursive business rule calls. 
 
So In our case, since we call "current.update()" in the Business rule, it will trigger "before" business rules again and due to this reason, we are seeing the incident state update twice.

 


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