Issue
Service Portal ticket conversation widget shows comments / worknotes and users can use this to communicate back and forth with the fulfiller and the receiver.
Cause
Ticket Conversation widget is designed to only show comments and worknotes. Other activities like field updates will not be shown
Resolution
The Ticket Conversation widget in Service Portal is designed to display only comments and worknotes.
*If you're an existing customer using the Service Portal (sp) portal for employee self-service use cases, we recommend that you migrate to the Employee Center (esc) portal for a better experience.