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My MID Server ECC Queue records have been Deleted. Where did they go? - Support and Troubleshooting
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  • My MID Server ECC Queue records have been Deleted. Where did they go?
KB0688184

My MID Server ECC Queue records have been Deleted. Where did they go?


2801 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

 

If you look at a Discovery Status form, you will see that the Discovery Log list contains a column for ECC queue input, and there is also a related list for all ECC Queue record generated by the Discovery job.

Those may be missing. 

Cause

The platform automatically deletes all ECC Queue [ecc_queue] table records once they are between 4-5 days old. This includes records for Discovery and other ITOM features that use the MID Server, plus various other integrations that use the ecc_queue.

This is done using the Table Rotations system, and is a deliberate strategy to prevent performance issues in relation to the table size, and the SQL JOINs used to tie the daily shards together when listing the whole table.

The Discovery Log records hang around a bit longer. Table Cleanup runs for discovery_device_history and discovery_log after 30 days.

Resolution

Re-running the job you are interested in would be the quickest and safest solution.

It is best not to change the Table Rotation settings, as this has caused severe performance incidents, especially in Production instances.

On a sub-prod test instance in theory you could get away with increasing the number of 'rotations' in the sys_table_rotation record for the ecc_queue table, perhaps to rotations=10 to guarantee week's worth of records, but don't over-do it.


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