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Symptoms


An admin user is asked to elevate to admin role when logging in. Users are not able to see the impersonate option before elevating the roles and might be asked to elevate to the admin role again once the session is timed out.

Release


All supported releases.

Cause


When the High Security plugin is enabled in the instance, users can make certain user roles elevated by checking the Elevated Privilege checkbox in the sys_user_role record form. This option sets the roles to session-specific privileges.

Resolution


If it is the admin role that is having the issue, uncheck the Elevated Privilege checkbox in the admin sys_user_role record to resolve the issue.

  1. Make sure that the High Security plugin is enabled.

  2. Navigate to the sys_user_role table.

  3. Search for and select the admin record or navigate to the following link:

    https://<instance-name>.service-now.com/nav_to.do?uri=sys_user_role.do?sys_id=2831a114c611228501d4ea6c309d626d

  4. Uncheck the Elevated Privilege checkbox.

  5. Save the record.

  6. Flush the cache and log in to the instance again after making this change.

Article Information

Last Updated:2018-05-30 06:45:07
Published:2018-05-30