13 views

Symptoms


Failed to load resource: the server responded with a status of 400 (Bad Request) when submitting catalog requests in service portal. This will cause the catalog item to not be submitted.

Release


Kingston

Cause


Active mandatory variable that is not on the catalog item form will cause the form to not be submitted.

Resolution


On the catalog item, look through all "Mandatory = True" variables, including in each variable set. One by one set these variables to "Mandatory = false" while trying to submit the catalog item. Once you have found the effected mandatory variable, use a UI policy to set this variable to "Mandatory = false" instead. 

Article Information

Last Updated:2018-06-01 01:10:57
Published:2018-05-23