Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Some update sets are loaded and the state remains at "Previewing" with no "Commit Update Set" button available. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Some update sets are loaded and the state remains at "Previewing" with no "Commit Update Set" button available.
KB0687603

Some update sets are loaded and the state remains at "Previewing" with no "Commit Update Set" button available.


1230 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Some update sets are loaded and the state remains at "Previewing" with no "Commit Update Set" button available.

Release


Kingston+

Cause


This issue can be caused by an old version of the "UpdateSetPreviewer" script include. 

Customization can prevent users from completing this update, while upgrading to Kingston from older releases of the platform.

Resolution


Convert the "UpdateSetPreviewer" script include to the out-of-box version:

  1. Go to System Diagnostics -> Upgrade History
  2. Open the record for the upgrade to Kingston.
  3. Under the Skipped Changes to Review tab, search for Target Name = 'UpdateSetPreviewer'
  4. Open the record and click the "Reverse to Base System" button

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.