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Symptoms


<sys_id> is being displayed on Glide List reference field instead of display value as shown in below screenshot,

Release


Any release.

Cause


Glide List can display a sys_id of a data from referenced table due to one of the following possible reasons,

Reference data doesn't exist in the referenced table:

For example consider a field called group on the incident table which refers sys_user_group table, and it has a value called "Test Group" with certain sys_id. When this "Test group" was deleted from the systems, incident record which refers the deleted group, will display its sys_id.

Referenced data is not accessible:

For example, when on the incident record, logged in user doesn't have access to the sys_user_group, system will display sys_id instead of display value of the data as it couldn't resolve the reference.

When the referenced table is set with display value as "sys id":

Display value of the referenced table should not be set to sys id, else system will display sys_id on the reference Glide list field.

When the referenced table is set with default value, but field is set as read-only on the dictionary level:

The Glide list reference field will resolve the reference at the server level to the default value, only if the field is editable on the server level, else system will not be able to resolve to the reference of the sys id set in the default value of the dictionary entry and would show sys id on the user interface.

In this scenario, to work-around the issue, you can set the field as editable on the dictionary/ACL (server) level and make it as read-only at the client side ( UI policy / client script), so that reference will be resolved at the server level and then field will be set as ready-only at the client level.

Below screenshot demonstrate this scenario,

When the referenced table is not writable due to customization:

Customer can have customization at the reference table in terms of ACL with scripts coming from script include or system properties, this can restrict accessibility to the field and can cause the sys id to be shown on the form. 

You need to review the custom script / properties to identify the cause of the issue.

Resolution


Check the possible caused mentioned above and take next steps accordingly.

Additional Information


https://docs.servicenow.com/bundle/geneva-servicenow-platform/page/administer/tablet_and_mobile_ui/task/t_GlideListItems.html

https://docs.servicenow.com/bundle/istanbul-platform-administration/page/administer/field-administration/concept/c_ReferenceField.html

Article Information

Last Updated:2018-06-14 05:33:07
Published:2018-06-14