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Why am I unable to find a record that was created in an ATF (Automated Test Framework) test after it completes? - Support and Troubleshooting
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  • Why am I unable to find a record that was created in an ATF (Automated Test Framework) test after it completes?
KB0687518

Why am I unable to find a record that was created in an ATF (Automated Test Framework) test after it completes?


2553 Views Last updated : Apr 10, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


  • Unable to find records that were created during an ATF test.
  • Data created during the test seems to be unavailable.

Release


Istanbul+

Cause


ATF rolls back all changes it makes, because it is designed for testing functionality and not for generating data.

Any data created throughout that specific test will be erased upon test completion.

Resolution


  • Records will not be available post-test, but they can be viewed while the test is still active (prior to rollback)
  • Users can add a validation step at the end of the test that will fail. As long as the validation evaluates to false, the test will wait patiently until the timeout. By default, the timeout is set to a maximum of 590 seconds (9.83 minutes).
  • More information is available here https://community.servicenow.com/community?id=community_blog&sys_id=80f34f3bdbc02b44fece0b55ca961990

 


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