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Event Management events stuck in 'Queued.' state. - Support and Troubleshooting
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  • Event Management events stuck in 'Queued.' state.
KB0687516

Event Management events stuck in 'Queued.' state.


3691 Views Last updated : Jul 15, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


- Events in em_event table are stuck in Queued states similar to below:
Queued.6d368322db021300eb319ee8db96194d
- Refreshing the scheduled jobs by changing the Event Management's property 'Number of scheduled jobs processing events' won't help. Restarting the nodes also won't help.
- Syslog shows StackOverFlowError similar to below:
---------------------------------------------------------------------
JavaScript evaluation error on:
var eventProcessor = new SNC.EvtMgmtEventProcessor(); eventProcessor.processWithLimit(0,34);
Root cause of JavaScriptException: java.lang.StackOverflowError 
---------------------------------------------------------------------

Release


This affects all releases with Event Management Plugin.

Cause


- There could be several different causes to this issue. Generally, it's an unexpected Java Error which Event Management code does not handle properly and quits.
- This Knowledge Article is for the specific StackOverflowError occurring when processing the events. This error is thrown if there is an Event Rule with Event Compose on an event's field and the field length is large (> 800 characters).

Resolution


As of May 21, 2018, the issue is currently being worked on in PRB1280468. 
 

Additional Information


Steps to Identify the issue:
=====================
- Turn on Debugging by going to Event Management > Settings > Properties and select 'Yes' for 'Display logs for debugging' property. Save.
- Wait a few minutes for the next execution of 'Event Management - process events' scheduled jobs to be completed.
- Goto em_event list view and show column 'Processing serviceNow node'
- For the events that are stuck in 'Queued' state, note the application node that processed the events under the 'Processing serviceNow node' column.
- Goto the node log (not the syslog) for the application node and search for logs around the time the scheduled job 'Event Management - process events' is triggered.
- Locate the 'StackOverflowError'. Prior to that, debug logging will show the Event Rule current being evaluated. Ex:
 10:21:32.180 Debug worker.6 worker.6 DEBUG: Found [1] matching rules. Best match is: name [<Event Rule Name> Event Rule] id [be95e984dbbdb200d5e15f6e5e961946]
 
Workaround:
=====================
- Disable the Event Rule found in 'Steps to Identify the Issue' section' to prevent Event processing from erring.
- Shortening the field in the event, where there is an Event Compose on that field in any Event Rules.

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