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Resolving Catalog item getting stuck at "submitting..." in Service Portal (Invalid Request 404 error on the console) - Known Error
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KB0687096

Resolving Catalog item getting stuck at "submitting..." in Service Portal (Invalid Request 404 error on the console)


3286 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When trying to submit a Record Producer and the "sc_cat_item" page is stuck at submitting and there is a 404 (Invalid Request) error on the console. This might be due to an exception on the nodelogs, Please see the below example

"...

2018-05-18 07:40:00 (719) Default-thread-3 D242BC9FDBCE9F00EEC724B3CA96190F txid=95747c93db02 WARNING *** WARNING *** Evaluator: java.lang.ClassCastException: com.glide.script.GlideElement cannot be cast to com.glide.script.glide_elements.GlideElementReference
Caused by error in <refname> at line 54
com.glideapp.servicecatalog.RequestNew.createRequestItem(RequestNew.java:308)

..."

If you don't the see the exception other than the Service Catalog Rest API error, Please add the item to the cart and then try to submit again.

Release


Kingston 

Environment


Browser, Service Portal

Cause


Change in Request Item Dictionary Data Type

Resolution


Please check the Dictionary Entry for these 2 fields "Item", "Short Description", "Opened by" and "Request" fields in Requested Items (sc_req_item) table and compare it with an OOB instance.


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