6 views

Symptoms


You are expecting a set of fields to be displayed in the reference popup window (which comes up when we click/hover on the reference icon), but they are missing or different set of fields are displayed. 

Release


Any release

Cause


 - In general, when user clicks on reference icon, system will look for the sys_popup view defined for that table/form, if it doesn't exist, system will utilize the default view for the popup window. 


- It is possible that user has customized the specific default view that required set of fields are removed or different set of fields are added on the view.

- If there is a sys_popup view exist for the specific table/form, it may not contain the required fields or it contains different set of fields.

Resolution


If there was no sys_popup view defined for the specific table/form, then follow below steps to correct the existing view to include the required fields

  • As an admin, navigate to the list, for example incident.list, it will load the case list 
  • Open any existing record from the list, it will open the record in default view 
  • On the case form, right click on the form header => Configure => Form Layout
  • On the slushbucket, select the fields which you needed on the popup window and click "Save" 


Now refresh the incident list and check reference icon to see whether it is picking up the updated default view. 

Else, if the sys_pop view exist, follow below steps and update the sys_popup view,

  • As an admin, navigate to the list, for example incident.list, it will load the case list 
  • Open any existing record from the list, it will open the record in default view 
  • On the case form, right click on the form header => Configure => Form Layout 
  • Select sys_popup view from the view name field
  • On the slushbucket, select the fields which you needed on the popup window and click "Save" 


Now refresh the incident list and check reference icon to see whether it is picking up the updated sys_popup view. 

In case, your business requirement demands that default view should not be modified, but only the popup window needs to be modified, then you need to create the sys_popup view as per below steps,

  • As an admin, navigate to the list, for example incident.list, it will load the case list 
  • Open any existing record from the list, it will open the record in default view 
  • On the case form, right click on the form header => Configure => Form Layout 
  • On the "View name" field=> select "New" 
  • Enter the view name as "sys_popup" 
  • Select the fields which you needed on the popup window and click "Save" 

Now refresh the incident list and check reference icon to see whether it is picking up the created sys_popup view. 

Additional Information


https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/field-administration/concept/c_ReferenceIcon.html. 

 

Article Information

Last Updated:2018-05-17 01:20:23
Published:2018-05-16