Issue
The reference pop-up window that displays when you click/hover on the reference icon does not display the correct fields or fields that are missing.
Cause
The information displayed in the reference pop-up window is determined by the sys_popup view defined for that table/form.
- If the defined view doesn't exist, the system uses the default view. If you have customized the default view, the required set of fields might be removed or a different set of fields added to the view.
- A sys_popup view exists for the specific table/form but it might not contain the required fields or contain a different set of fields.
Resolution
If no sys_popup view is defined for the specific table/form, correct the existing view to include the required fields:
- As an admin, navigate to the list (for example incident.list), which will load the case list.
- Open any existing record from the list.
- The record will open in the default view.
- On the case form, right-click on the form header and choose to Configure > Form Layout.
- Use the slushbucket, select the fields you want to display in the pop-up window, and click Save.
- Refresh the incident list and check the reference icon to see whether the pop-up window is displaying the updated default view.
If the sys_pop view exists but does not contain the correct fields, update it.
- As an admin, navigate to the list (for example incident.list), which will load the case list.
- Open any existing record from the list.
- The record will open in the default view.
- On the case form, right-click on the form header and choose to Configure > Form Layout.
- Select sys_popup view from the view name field.
- Use the slushbucket, select the fields you want to display in the pop-up window, and click Save.
- Refresh the incident list and check the reference icon to see whether the pop-up window is displaying the updated default view.
- If the default view should not be modified but you can modify only the pop-up window, create the sys_popup view.
As an admin, navigate to the list (for example incident.list), which will load the case list.
- Open any existing record from the list.
- The record will open in the default view.
- On the case form, right-click on the form header and choose to Configure > Form Layout.
- In the View name, click New.
- Provide the view name as "sys_popup".
- Select the fields that you want to display in the pop-up window and click Save.
- Refresh the incident list and check the reference icon to see whether the pop-up window is displaying the updated default view.
Related Links
Reference field icon product documentation topic