Issue
Symptoms
The translations for a catalog item are no longer visible post catalog item import/ retrival of a catalog item from one instance to the other.
Release
All releases
Cause
The issue occurs due to importing table data for sys_translated_text and sys_translated table prior to retrieving and committing the catalog item that would use the translation.
Looking under the sys_translated_text table, one would find that there is no record associated to the sys_id of the catalog items.
Resolution
Create the translations under sys_translated_text and sys_translated table after the creation of their respective catalog item, so that the sys_id's match. Post that, move the catalog item and translation to the next instance.