48 views

Symptoms


Users report that after adding UI Action like Edit or New in related list users still do not see the button. 
 
Few things to check in the list control:
- Omit new button checkbox is false.
- Omit edit button checkbox is false.
 
1. From the Related List header (e.g. Change Request related list), select Configure > UI Actions. 
 
2. Search for the UI Action ("New" or "Edit") created for Change Request table. 
 
https://<instance>.service-now.com/sys_ui_action_list.do?sysparm_query=table%3Dchange_request%5EORtableINchange_request%2Ctask%5EnameSTARTSWITHNew 
 
3. Open the UI Action (e.g New): 
 
4. Check the condition  "!RP.isRelatedList()".

Release


Any ServiceNow Release

 

Cause


!RP.isRelatedList() in the UI Action condition causes New UI Action (button) NOT to be visible in the Related List. 

Resolution


To make UI Action "New" to appear in the Related Lists check and remove the condition "!RP.isRelatedList()" in the related list or use RP.isRelatedList() as condition.

Additional Information


How to troubleshoot UI Actions either or not showing or not working

Article Information

Last Updated:2018-06-01 01:24:45
Published:2018-05-15