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Non-admin users are unable to see all the (non-active) records in the sys_user table - Support and Troubleshooting
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KB0686188

Non-admin users are unable to see all the (non-active) records in the sys_user table


2801 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Non-admin users are unable to see all the (non-active) records in the sys_user table though they have read access.

Release

All the available releases

Cause

There is a query business rule called "user query" on the sys_user table which allows only admin users to view all the records. As you may see in the business rule, the user will need to have admin role to see all the records in the sys_user table. Otherwise, it will return only active records. "addActiveQuery' adds a filter to return all active records.

Resolution

In order to allow all the users who has read roles to the sys_user table to view all the records, the user will have to modify the condition of the business rule  to add roles or turn off the business rule itself. The business rule can be found here.

https://<instance-name>.service-now.com/nav_to.do?uri=sys_script.do?sys_id=62a7bfaf0a0a0a6500c49682bd82376a


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