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Why chat disappears at the end user side, when agent transfers it to another queue? - Support and Troubleshooting
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KB0686066

Why chat disappears at the end user side, when agent transfers it to another queue?


568 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When the chat disappeared at end user side, you may observe below error on browser console,

Conversation <sys_id> does not exist.


While opening the disappeared conversation in connect mini window, you may observe below message,

security prevents viewing this conversation.

Release


Jakarta 

Cause


Custom business rule was updating the opened_by field of chat_queue_entry record with agent sys_id and hence Chat logic fails. 

Resolution


Review the custom business rule and set the condition of business rule as "sys_class_name != chat_queue_entry" so that business rule will not be executed for chat_queue_entry and hence chat logic would work as expected. 


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